Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Download

iControl Ruby Library

This download is secured and you do not have access. Please login or register to view downloads.
Comments on this Download
Comment made 23-Sep-2013 by Jesse Reynolds 0
"Download the iControl Ruby Library Gem" you say. How? Where?
2
Comment made 24-Oct-2013 by crosson 120
The red button below titled "11.03.00" Side note the updated lib appears to work in ruby 2.0.0. /cheer
1
Comment made 25-Jan-2014 by Jonathan Thurman 0
Sure would be nice to have this on rubygems.org to make installation / updating easier.
6
Comment made 28-Mar-2014 by SeanW 3
Another vote for putting this up on Rubygems or having the source up on GitHub. Would also allow easier management through bundler and to contribute back. If it's a knowledge/time thing, I'd be happy to help out. I know that supporting a bunch of languages can be difficult and Ruby has it's particular challenges.
5
Comment made 08-Aug-2014 by Jake M 1
Why is this gem artifact not hosted on rubygems.org since it's available publicly to make it easier to install/update? Why not host the code on github.com to allow people to contribute to the code?
3
Comment made 11-Aug-2014 by Joe 04 1
The download link is here on the page (the big red button that says Download) but YES, please for the love of all things holy make this available on Github or Rubygems so it fits the workflow of every other Ruby gem on the planet (gem install ...).
2
Comment made 18-Sep-2014 by Graham Ballantyne 0
Another vote for putting this up on rubygems.org so bundler works.
3
Comment made 06-Jul-2015 by Jeff H. Silverman at Disney 1
I have downloaded the 11.4 version of the software. I have a couple of examples that actually work. But where is the documentation that tells me how to actually use the software?
1
Comment made 06-Jul-2015 by Jeff H. Silverman at Disney 1
I have downloaded the 11.4 version of the software. I have a couple of examples that actually work. But where is the documentation that tells me how to actually use the software?
0
Comment made 15-Mar-2016 by hippiehacker 1
I exported this GPL gem to https://github.com/hh/f5-icontrol so that someone at F5 could publish it to rubygems. Joe Pruitt or George Watkins are you still around?
0
Comment made 15-Mar-2016 by hippiehacker 1
I have some open issues which I created at https://github.com/hh/f5-icontrol/issues I'm asking Rackspace/NetSec to reach out and coordinate with F5/DevCentral in fixing these.
0
Comment made 15-Mar-2016 by SeanW 3
I have my own, modernized, version up at https://github.com/swalberg/f5-icontrol, and it's also up on Rubygems.
0
Comment made 25-Mar-2017 by Eric Ji

Hi, I installed f5-icontrol-11.4.1.0, and was running into the following issue. Did I miss anything? appreciate your help! thanks -Eric

scs@chefserver:/var/lib/gems/2.3.0/gems/f5-icontrol-11.4.1.0/examples$ sudo ruby get-version.rb 10.192.74.111 -u admin -p admin

/var/lib/gems/2.3.0/gems/soap4r-1.5.8/lib/xsd/charset.rb:13: warning: variable $KCODE is no longer effective /var/lib/gems/2.3.0/gems/soap4r-1.5.8/lib/xsd/xmlparser.rb:74:in <top (required)>': XML processor module not found. (RuntimeError) from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:inrequire' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in require' from /var/lib/gems/2.3.0/gems/soap4r-1.5.8/lib/wsdl/parser.rb:12:in<top (required)>' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in require' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:inrequire' from /var/lib/gems/2.3.0/gems/soap4r-1.5.8/lib/soap/wsdlDriver.rb:9:in <top (required)>' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:inrequire' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:in rescue in require' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:40:inrequire' from /var/lib/gems/2.3.0/gems/f5-icontrol-11.4.1.0/lib/f5-icontrol.rb:2:in <top (required)>' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:inrequire' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:in rescue in require' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:40:inrequire' from get-version.rb:4:in `

'

0