Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Download

iRule Editor

This download is secured and you do not have access. Please login or register to view downloads.
Comments on this Download
Comment made 09-Sep-2013 by Hem 198
I've a problem with irule editor.Im losing offline irules as soon as i close the device. Everytime i open editor,im losing all offline rules.
-2
Comment made 09-Sep-2013 by Joe Pruitt 6270
The Editor stores the files in the "%Program Data%/F5 Networks/iRuler/Offline" folder. If you click on the File.Archive."Open Archive Folder" location and go up a level you should see an "Offline" folder. Are the files in there and just not showing up when the Editor starts or are they not there at all? I'm wondering whether the Editor is failing to display them at startup or if it's failing to save them during creation.
0
Comment made 04-Oct-2013 by Ajmal 56
Can we have a find & replace option in the search menu?
0
Comment made 04-Mar-2014 by Kevin Davies 2478
Running on Mac OSX https://devcentral.f5.com/questions/irule-editor-on-mac-osx-1092-mavericks
-1
Comment made 12-Mar-2014 by angelfyr 0
is there a way to check in the editor if the device is active or not without going through the actual f5 interface?
0
Comment made 05-Jun-2014 by godidea 0
Very good tools~
0
Comment made 28-Aug-2014 by DavidScottNorton 2
So Sorry to see this all but dead:( Any way you could release the code so it can be brought up to a new version of .net and maintained?
1
Comment made 02-Sep-2014 by JohnDonovan 0
iRule editing is available on LTM v11+; Ensure you are in the appropriate partition for your iRule; Open System --> File Management --> Data Group File List; Create or edit your iRule; Click Update All done! :-)
-1
Comment made 23-Sep-2014 by michaelwong 1
Hi @Joe Pruitt: My irule editor cannot work well, it have no full syntax highlighting, colorization, textual auto-complete. My PC: windows 8 enterprise x64 + .NET Framework 3.5(incloud .net 2.0 and 3.0) +irule editor version 0.11.0.2 please help me !
2
Comment made 25-Sep-2014 by Jason Rahm
Hi all, new update fixes iRule wiki links from the editor, as well as a major update of command/event keywords. Grab version 11.0.6
1
Comment made 29-Sep-2014 by michaelwong 1
Hi ALL: My irule editor cannot work well, it have no full syntax highlighting, colorization, textual auto-complete. My PC: windows 8 enterprise x64 + .NET Framework 3.5(incloud .net 2.0 and 3.0) +irule editor version 0.11.0.2 please help me !
2
Comment made 03-Oct-2014 by Brad Parker 4465
Thank you Jason Rahm for the update. Is there any way we could get it to work with TLSv1.2? We recently were asked to enforce TLSv1.2 on the management network and since the editor can not connect to the devices. Thanks in advance.
0
Comment made 28-Oct-2014 by Arie 2069
Version 11.00.06 seems to contain a bug in the Data Group Editor. It does not display the values of key-value pairs. Since the entire class is re-created when changes are made this results in the loss of all values (the keys are preserved).
0
Comment made 10-Nov-2014 by Arie 2069
Thanks for fixing the problem with the data classes!
0
Comment made 16-Feb-2015 by Jason Antman 5
The link above to a question about running it on Mac seems to be broken. So this thing will only run on Windows? Or, at best, Windows and Mac? So a company that makes Linux-based appliances gives us a tool that won't run on Linux? Great. Useless to my entire team.
4
Comment made 12-Mar-2015 by Hendry Chandra
Was using iRules Editor version 0.11.0.2 and trying to connect to BIG-IP on remote data center. The SSL VPN application provided by customer maps the IP-Port of BIG-IP to 127.0.0.1:4431. When I try to connect to 127.0.0.1:4431 using the iRules editor, I keep getting "Invalid Connection Information..." error message. However when I open a browser (any browser, with no proxy) and open "https://127.0.0.1:4431", I got the BIG-IP Web GUI. Upgrading the iRules editor (to version 0.11.6.1) does not seems to help. I have a BIG-IP VE on my VMware, and both the Browser and the iRules editor can connect to the VE version fine. Seems I missed something.
0
Comment made 03-May-2015 by Robert 534
Hi,Joe I want to add irule in a folder ,such as /Common/folder_name/irule_name,but I can'f achieve this in "File---New" in irule editor Is there a way to do this? If it is not doable at this moment,does F5 has ETA for this feature? Thanks for your great help
0
Comment made 14-May-2015 by Renato@DimensionData 455
How can I see the iRules from other partitions? It's only listing from the /Common.
1
Comment made 20-May-2015 by George 0
Is there a way to syntax check iRules ahead of an upgrade from v10 to v11?
4
Comment made 29-Sep-2015 by labota 0
how i can install this app and use it ????
0
Comment made 06-Oct-2015 by Torsten 6
I have an feature request: Please add the possibility when assigning an irule to virtual servers to select multiple servers. When assigning a generic rule to all servers it is currently a point and click marathon :)
0
Comment made 19-Oct-2015 by Silou 0
Hello, I have the same Problem with the version 0.11.6.1 - Seems related to windows : From my point of view, each offline irule is copied into the the "Offline" folder as simple text files and on windows, it's not authorized to create text files that contains "/" in their names so for example : "/Common/xxx" will not work. We just updated our F5 from 10.x to 11.x and I'm can still see my old Offline iRules that doesn't contain "/Common/xx"
1
Comment made 13-Nov-2015 by Georgi 'Joe' Stanchev 178
Any chance to add source beautifier or source format? Will be really cool feature or at least auto tab/space fix.
0
Comment made 13-Nov-2015 by Georgi 'Joe' Stanchev 178
Any chance to add source beautifier or source format? Will be really cool feature or at least auto tab/space fix.
0
Comment made 04-Feb-2016 by Emad 553
Not working after windows-10 upgrade. DotNet framework not compatible. any solution ?
0
Comment made 10-Feb-2016 by Joe Pruitt 6270
On the Win-10 upgrade, not sure what's going on. You may have to go and install an older version of the .net framework on the box. I don't recall buildling it with a specific version dependency but I'll have to go and double check.
0
Comment made 16-Feb-2016 by sas 01 0
i am not able to connect to the editor with the credentials bigip.f5demo.com admin account it says invalid connection information , any ideas ? and i don't see offline templates as well ?
0
Comment made 17-Feb-2016 by AaronMLong 246
What versions of TLS does the F5 iRule editor support? I removed TLS1.0 support from my default clientssl profile, and now I seem to be unable to successfully connect my iRule editor to my BigIP.
1
Comment made 28-Feb-2016 by hiedige8 0
thank you for share
0
Comment made 04-Mar-2016 by B Torres
Please note that when using 11.6.1 F5 iRule Editor with a unit running v12 HF1, you will get an error "Invalid Connection Information..." when using the hostname, if you use the Management IP then it works. Additionally, on v11.6.0 HF6, you will get the same error if you use the hostname but only when it has an additional white space after the hostname. Same issue was reported on https://devcentral.f5.com/questions/irule-editor-vs-tmos-v120
2
Comment made 11-Mar-2016 by mrbusdriversir2 0
My AV complains that the zip file has a trojan. Is this an official download?
0
Comment made 11-Mar-2016 by umiotoko 12
I'm being prevented from opening the ZIP file due to "infection".
0
Comment made 12-Apr-2016 by JAG 0
Comment made 2 months ago by Joe Pruitt ​F5 On the Win-10 upgrade, not sure what's going on. You may have to go and install an older version of the .net framework on the box. I don't recall buildling it with a specific version dependency but I'll have to go and double check. >Any update on iRule Editor v11.6.1 working with Windows 10. I have the same issue. The initial splash screen will display but then windows popup states the iRule editor has stopped working. I have reinstalled it and have set every compatibility setting combination possible but with no success. I have confirmed I have .Net 3.5 (includes v2.0) as well as .Net 4.6 installed.
0
Comment made 13-Apr-2016 by Arie 2069
Until F5 decides to officially support the iRule Editor it looks like it'll continue to be a boondoggle. The editor is a great concept and the intellisense feature is exceedingly hepful, but there have been some troubling problems with the editor (some leading to data loss) and the updates are few and far between. Even some of the content on this page is outdated by more than three years (e.g. the version mentioned in the posting is still "0.11.0.1 - 2011/10/19" - although the link goes to version 11.6.1).
0
Comment made 21-Jun-2016 by Dojs 109
I can't connect it using 12.1
4
Comment made 27-Jun-2016 by THE KING 18
Hi, Very good tools
0
Comment made 09-Aug-2016 by Yuval BA 2

Are version 12.0 or above supported? I can't connect to 12.0 device.

0
Comment made 01-Sep-2016 by Bo Bang Larsen 0

I have problems connecting to 12.1 devices if I use the DNS name for the BIG-IP. If I use the mgmt ip address it works.

1
Comment made 04-Oct-2016 by TLL 332

Thanks, just had the same issue connecting to a 12.1.1. Using IP works.

0
Comment made 14-Dec-2016 by Mikeheyu 0

thank you very much form beijing china

0
Comment made 04-Mar-2017 by Huaiqing Cheng 0

for Mac ? I need one for Mac

0
Comment made 10-Mar-2017 by Renato@DimensionData 455

Would be nice to have a portable version.

0
Comment made 15-Mar-2017 by Federico Teti 63

For those looking for an alternative for Mac I highly recommend to utilize this post as a reference. Works flawessly https://devcentral.f5.com/articles/f5-programmability-for-eclipse-installation-instructions-20883

0
Comment made 06-Apr-2017 by raddboy41 0

Agreed, must use IP addresses with v12.1.2. Silliness really.

1
Comment made 18-Aug-2017 by EuropeanITCrowd 64

Cannot connect using TLS1.2. iRuleEditor connects with only TLS1.0

1
Comment made 27-Sep-2017 by Riitesh Bhachawat 0

It seems that the connection can be made to 12.1.1 through IP address only. Is there any way to connect / support through TLS1.2.

5
Comment made 20-Aug-2018 by Juerg Wiesmann

Not amused to say, that iRule Editor is not able to connect to a BIG-IP on Version 14.0. I will open a case for it to find out what the issue is... Support did not want to help here, as it is still not a supported tool. So sadly seen this feedback..

0
Comment made 20-Aug-2018 by crodriguez

The issue is documented (a little sideways) in v14.0 release notes, as shown below. Might I suggest the F5 Editor Eclipse Plugin v2, as described by Jason Rahm here on DevCentral: https://devcentral.f5.com/articles/f5-editor-eclipse-plugin-v2-29402

FROM BIG-IP v14.0 RELEASE NOTES:

668624 : The Configuration Utility now disables the TLS 1.0 protocol by default★ Component: TMOS

Symptoms: The TLS 1.0 protocol was removed from the list of SSL protocols allowed by default in the management utility. This impacts the iControl REST API, and if you are using configuration management tools like Ansible (which uses Python) compiled with an older OpenSSL version, this will cause the client to suddenly fail to connect with an error similar to the following: SSLError: EOF occurred in violation of protocol.

The protocol defaults can be seen with the following tmsh command:

# tmsh list sys httpd ssl-protocol
sys httpd {
   ssl-protocol "all -SSLv2 -SSLv3 -TLSv1"
}

Conditions: This can occur when connecting to the configuration utility, including using the iControl REST API, with an HTTPS client that is not compiled with TLS 1.1 or TLS 1.2 support.

Impact: BIG-IP systems refuse to allow TLSv1 connections, so the client will be unable to connect. This will most likely be encountered as a sudden inability to connect after upgrading.

Workaround: While TLS 1.0 can be re-enabled on BIG-IP systems via the 'tmsh modify sys httpd ssl-protocol' command, this is not advised because the protocol is past the end-of-life date. It is highly recommended to upgrade the OpenSSL version on all client devices that connect to the BIG-IP configuration utility.

Fix: TLS 1.0 is no longer in the default SSL protocols list, and all SSL clients need to have support for TLS 1.1 or 1.2 or they will be unable to connect.

Behavior Change: The configuration utility no longer allows the TLS 1.0 protocol by default. The following tmsh command shows the before and after settings:

Prior to version 14.0.0:

# tmsh list sys httpd ssl-protocol
sys httpd {
   ssl-protocol "all -SSLv2 -SSLv3"
}

Beginning in version 14.0.0:

# tmsh list sys httpd ssl-protocol
sys httpd {
   ssl-protocol "all -SSLv2 -SSLv3 -TLSv1"
}

All clients connecting via SSL must have support for TLS 1.1 or 1.2 or they will be unable to connect.

0
Comment made 3 months ago by JoeTheFifth 301

those looking for a portable version may use this soft to create a portable exe. I used it and it works fine: http://www.cameyo.com/downloads/

0
Comment made 1 month ago by Jake 0

This is a great help, though it does not handle RSA keyfob logins well.

0