Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Accessing XenDesktop via APM, Citrix Desktop Viewer not displaying

Environment: BIG-IP 4200v, LTM 11.5.2 plain, with APM fully licensed

We have integrated Citrix by adding a Remote Desktop for which the destination is a pool of Citrix XML brokers. That all works well in general. However, when users access a remote desktop via this approach, they report that they are not able to access the toolbar that has a Ctrl-Alt-Del button. When they access directly via a Citrix Web Storefront interface to the same application server, they are able to access the toolbar.

I'm pretty convinced it has to be something in the ICA file delivered from the F5 that's different - but not completely sure. There are differences, if you compare the F5-delivered ICA and the WSF-delivered ICA ... but none are obviously involved. Based on articles online, I did add to the F5 Custom Parameters for the Citrix ICA the following:

  • ConnectionBar=1
  • ShowDesktopViewer=On

And I've confirmed those values are being added to the F5-delivered ICA, but it doesn't appear to have helped.

Thoughts? Thx.

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Try adding [Application] at top to citrix remote desktop profile custom parameters field:

[Application]

ConnectionBar=1

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I already have ConnectionBar (and ShowDesktopViewer) settings in the [Application] section of the ICA. But never mind, i found the problem! It turns out that the web plugin version I was using simply doesn't display the connection bar, no matter what is in the ICA. When I switched to a version that matches our user population in the field, ConnectionBar=1 (or possibly ShowDesktopViewer=On) had already worked, I just didn't know it until the switch.

Thank you!

0