Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Clear all filters
Answers

AMQP traffic load balanced through VS

We are trying to LB rabbitMQ (AMQP). The traffic on a Standard VS will load balance to the pool members and we put the irule for proxy protocol (https://devcentral.f5.com/codeshare/proxy-protocol-initiator) as well as the line that enables proxy protocol in rabbitMQ.conf. The network times out when we make a call to the VS right after it attempts to start a RabbitMQ Subscriber. Anyone have similar hirdles they've had to jump over? Sorry I don't have much information to give you-please ask any questions that you think might help!

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Any luck?

0
Comments on this Answer
Comment made 10-Oct-2018 by Darren Walker 226

we specified tls1.2 in the rabbitmq.conf and now we have a standard virtual server on port 5671 working.

0
Comment made 10-Oct-2018 by AlexLP 121

Just to verify, you are securing the messages with tls1.2?

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I have been asked to configure this type of setup with RabbitMQ on our F5s.

I'm not having any luck with standard vs nor performance layer 4 configurations using unsecured 5672 or 5671. We see network connection errors in the rabbitmq log files.

Besides configuring the rabbitmq.conf file to allow tls1.2 and proxy protocal-Did you enable SSL client on the standard 5671 vs configuration? And was there anything special from an SSL standpoint on the backend server?

0