Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Applying Analytics profile to VS changes chunking behavior?

Hi,

I was doing some test (v11.2.0HF7) and for some reason two almost identically configured server was delivering different responses to the client:

  • One chunked
  • Second not chunked

Both VS were sending traffic to the same backend server, using same settings for Response Chunking: Selective

After long trial&error it turned out that disconnecting Analytics profile from VS disables chunking of the reply send to client.

Why so? Is that bug or expected behavior?

In Analytics profile options enabled as below:

ltm profile analytics my-analytics {
    alerts none
    app-service none
    captured-traffic-external-logging disabled
    captured-traffic-internal-logging enabled
    collect-geo disabled
    collect-http-throughput enabled
    collect-ip disabled
    collect-methods enabled
    collect-page-load-time enabled
    collect-response-codes enabled
    collect-server-latency enabled
    collect-url enabled
    collect-user-agent disabled
    collect-user-sessions disabled
    collected-stats-external-logging disabled
    collected-stats-internal-logging enabled
    defaults-from analytics
    description none
    notification-by-email disabled
    notification-by-snmp disabled
    notification-by-syslog disabled
    notification-email-addresses none
    partition Common
    remote-server-ip any6
    remote-server-port 514
    remote-server-syslog-facility local0
    sampling-ratio 1
    session-timeout-minutes 30
    smtp-config none
    traffic-capture {
        capturing-for-my-analytics {
            app-service none
            captured-protocols all
            client-ips none
            methods none
            node-addresses none
            request-captured-parts headers
            request-content-filter-search-part none
            request-content-filter-search-string none
            response-captured-parts headers
            response-codes none
            response-content-filter-search-part none
            response-content-filter-search-string none
            url-path-prefixes none
            user-agent-substrings none
            virtual-servers none
        }
    }
    trust-xff enabled
}

Is any of above setting forcing VS to send chunked response to client?

Piotr

0
Rate this Question
Comments on this Question
Comment made 2 months ago by Piotr Lewandowski 1109

OK, should first search AskF5. I found article (A BIG-IP Analytics profile may impact response chunking for the associated HTTP virtual server but according to it on version I am using it was fixed, and I was not using HTTP Compression profile.

So not exact match, wonder what else could be a reason?

Piotr

0

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Please disable the following and try again:

collect-page-load-time enabled -> Change to disabled.

0
Comments on this Answer
Comment made 2 months ago by Piotr Lewandowski 1109

Hi,

Thanks I will try that and come back with results.

Piotr

0
Comment made 2 months ago by Piotr Lewandowski 1109

Hi,

Unfortunately it is not fixing issue. Even with only Throughput selected in Collecting Metrics after assigning profile replies are chunked.

Piotr

0