Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Basic HTTP Authentication - how to enable Basic Auth Realm?

Hi there, I have basic HTTP authentication working so I am prompted for username/password and realm defined on server. And when I enter the correct username/password everthing is fine. Now if I enter the wrong username/password - I get a prompt but it is for the same realm(the one defined on the server) and not the string I entered in Basic Auth Realm on Big-IP. How do I use the Basic Auth Realm setting?

Below is my config:

ltm virtual /Common/vs_http  { 
destination /Common/10.10.1.100:80
ip-protocol tcp
mask 255.255.255.255
pool /Common/pool_http
profiles {
    /Common/my_http { }
    /Common/tcp { }
}
source 0.0.0.0/0
translate-address enabled
translate-port enabled
}

ltm profile http /Common/my_http {
accept-xff disabled
app-service none
basic-auth-realm honhon
defaults-from /Common/http
encrypt-cookies none
.... 
}
0
Rate this Question

Answers to this Question