Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

BIP-IP 1600 VLAN bridge performance degradation

Hello,

I have a BIP-IP 1600 series setup as part of my thesis work.

The setup is as follows:

    (VLAN=20) Client1 ---   F5  --- Server1 (VLAN=10) 572 Mbit/s.

              Client1 --- Cisco --- Server1 (No VLAN) 937 Mbit/s

In the setup I have two VLANs, one public and one private. I do bridge'ing between the VLANs in the BIG-IP, but for some reason that downgrades the performance. In the bridge'ed setup with two machines directly connected to the BIG-IP on two separated VLANs the reported speed is around 572 Mbit/s.

For a normal link the iperf reported speed is 937 Mbit/s when the traffic is only directed through a cisco switch.

Is this normal behavior for the BIP-IP to degrade the performance, or I am doing something wrong?

Thanks!

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
First, this isn't an apples-to-apples comparison. The 1600 is an ADC, not a switch, and this model does not include hardware acceleration. The switch is just that - an L2/3 switch with no need to process each packet in software. The cause of the reduced throughput is probably latency inserted by the LTM. The 1600 doesn't have an ePVA, so all traffic is handled in software. Under ideal conditions this will delay each packet in both directions by ~20-29 ms latency. The switch has no such requirement and is most likely forwarding each packet at nearly line-rate. When testing throughput, overcome latency with concurrency - increase the number of traffic streams. I expect that, unless the CPU reaches peak usage, you'll see full throughput with only a few concurrent streams.
0