Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Citrix Slowness Using APM

Anyone using F5 APM to replace Citrix Storefront experiencing any slowness? We are using APM for external access, internal clients use Storefront. We are getting reports of external clients who have no issues with the initial connection but after a few hours of being connected they start to experience the slowness. The clients report slow keyboard and mouse response, apps freezing. Internal clients using Storefront do not report this behavior. The F5 APM is located in a DMZ and goes through a number of firewalls to get to the Citrix XenApp servers. We are working with our network team take packet captures to analyze, however wanted to ask if anyone else experienced this issue or would know what to look for regarding troubleshooting.

0
Rate this Discussion

Replies to this Discussion

placeholder+image

How did you deploy your F5 APM? Did you use an iApp? What TCP profile is assigned to your APM Virtual Server?

0
Comments on this Reply
Comment made 21-Sep-2016 by FI 2016 255

Thank you Michael, we deployed using an iApp.

Using the following TCP profiles Client - custom WAN optimized profile (parent profile tcp-wan-optimized, idle timeout 1800 seconds, keep alive interval 75 seconds) Server - custom LAN optimized profile (parent profile tcp-lan-optimized, idle timeout 1800 seconds)

Also, just to add, when the client is experiencing the slowness, they report that if they log out of the session and then reconnect, it temporarily resolves the slowness.

0
Comment made 22-Sep-2016 by Michael Koyfman 2088

definitely strange. I would suggest trying to change clientside TCP to be the same as serverside (custom LAN optimized profile) and see if it makes a difference

0
Comment made 22-Sep-2016 by Carl Brothers

If what Michael suggested does not work, the following are what we would normally set for the client side WAN profile:


defaults-from /Common/tcp-wan-optimized
    idle-timeout 1800
    keep-alive-interval 75
    nagle disabled
    pkt-loss-ignore-burst 8
    pkt-loss-ignore-rate 10000
    proxy-buffer-low 65536
    receive-window-size 1048576
    selective-nack enabled
    send-buffer-size 1048576
    syn-rto-base 200

0
Comment made 22-Sep-2016 by FI 2016 255

Thank you Michael and Carl. I am going to try these and see if it helps.

0