Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Clear all filters
Answers

Err Content Length mismatch???

So, when I put a VS behind a policy I get this error ERR_CONTENT_LENGTH_MISMATCH WHY? I have tried everything. Any help would be nice. It happens in Chrome. I have searched F5 docs and found nothing.

0
Rate this Question
Comments on this Question
Comment made 19-May-2017 by Tikka Nagi

What version of BIGIP is this happening on? Have you taken a tcpdump and reviewed the HTTP Request to ensure content length matches with the actual data?

tcpdump -i 0.0:nnn -w /var/tmp/xyz.pcap host and host

Do you see any errors in /var/log/ltm and /var/log/asm at the time of the request?

0
Comment made 1 month ago by Habib Ulla Khan 274

You can write irule below and check.

when HTTP_RESPONSE { HTTP::disable }

map this to vs .

0

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

JG2017 have you tried adding response chunking in http profile to rechunck or selective. Regarding what is causing mismatch. you need to capture traffic using http watch or fiddler.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Have you managed to solve the issue? we have the same problem. we tried to configure custom http profile and with different mode in request/response chunking but didn't help.

we have 12.1.3 version

Noticed in traffic capture a FIN ACK packet sent from the VS to the client.

2098    51.973914   10.140.52.29(VS)    1.1.1.1(client ip address)  TCP 174 [TCP Previous segment not captured] 443 → 56877 [FIN, ACK] Seq=80779 Ack=63589 Win=65535 Len=0

2099    51.973897   10.140.52.29    1.1.1.1  TCP    16587   [TCP Retransmission] 443 → 56877 [PSH, ACK] Seq=64366 Ack=63589 Win=65535 Len=16413

2100    51.974369   2.2.2.2(website ip address) 1.1.1.1 TCP 176 443 → 56877 [FIN, ACK] Seq=1 Ack=1 Win=65535 Len=0

2102    51.974553   10.140.52.29    1.1.1.1 TCP 267 443 → 56877 [RST, ACK] Seq=80780 Ack=63589 Win=0 Len=58
`</pre>

Image Text

If the LTM virtual server is configured in "performance" mode instead of "standard" mode, the issue resolved!

I configured the irule provided here : https://devcentral.f5.com/questions/request-content-length-differs-from-actual-request-body-length-site-59065 too see if browser lenght and f5 lenght is not he same but they were the same:

Jan 19 10:15:38 slot2/f5 info tmm6[9013]: Rule /partition1/test_content-lenght <HTTP_REQUEST>: Checking content length 156 IP: 1.1.1.1%2
Jan 19 10:15:38 slot2/f5 info tmm6[9013]: Rule /partition1/test_content-lenght <HTTP_REQUEST_DATA>:  length receive by F5: 156 

We also configured new http profile with custom "Maximum Header Size"=65536 and "Maximum Header Count"=80 .. didn't help

Does anyone came across this issue before?

0