Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

F5 13.1.1.2 & Grafana 5x - Dashboards not populating

Grafana is not populating the virtual servers, reverse engineered grafana datasource.js file & sent a REST call to F5 management interface to get the response on SOAP UI - passed in the correct headers & json request - Got an [] back for /mgmt/tm/util/admdb "utilCmdArgs": "list-metrics /shared/admdb/default/vs -

{ "kind": "tm:util:admdb:runstate", "command": "run", "utilCmdArgs": "list-metrics /shared/admdb/default/vs", "commandResult": "[]\n" }

but if I use other API's for listing the virtual servers & stuff - i am able to get back expected results.

We followed the steps provided in https://github.com/f5devcentral/f5-bados-app and https://devcentral.f5.com/d/behavioral-ddos-grafana-dashboard-using-big-ip-apis-244 - I have posted my questions there as well and to F5 support

Also, tmsh modify sys db admdb.debug.traffic.sample value enable doesnt work on 13.1.1.2. Any help is appreciated. TIA !

0
Rate this Question
Comments on this Question
Comment made 1 week ago by Jiri Rosenmayer 20

Similar problem here. No VSs showing. Running 13.1.1 for request {command: "run", utilCmdArgs: "list-element "/shared/admdb/default/vs""} this answer {"kind":"tm:util:admdb:runstate","command":"run","utilCmdArgs":"list-element \"/shared/admdb/default/vs\"","commandResult":"ls: cannot access\n"}

0
Comment made 6 days ago by g-ram 121

Thanks Jiri - I did more poking around & found that some of the REST API calls are getting a valid response from F5. F5 support recommended that Behavioral DDoS is enabled to send data to Grafana - which we did & still dont see any data on Grafana. Question for you - was this working on previous F5 / Grafana versions for you or this is the first time that you are trying this out as well ?

0

Answers to this Question