Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

F5 irule editor displays error while saving irule

We have a lot of irules which has common logic. We started to refactor the common logic to a separate common library irule adding procs and used these procs in the other irules. Using the F5 editor i wanted to add a new proc to the common library irule and while trying to save the change it complains with the following error

Exception caught in LocalLB::urn:iControl:LocalLB/Rule::modify_rule() Exception: Common::OperationFailed primary_error_code : 16908342 (0x01020036) secondary_error_code : 0 error_string : 01020036:3: The requested rule (/Common/test-irule) was not found.

The test-irule mentioned in the error message was deleted because we used it to test procs in the common library irule and after our testing we deleted it. But f5 irule editor seems to look for it when i change the common library irule.

If add back the test-irule and then make the change to the common library irule the save works. Has anyone faced this problem ? any help is appreciated

0
Rate this Question
Comments on this Question
Comment made 29-Jan-2016 by Theo 380
I've not seen it before. I'm assuming you tried to disconnect and reconnect. I would check your archive folder looking for any reference to it, and/or possibly clear your connection history.
0
Comment made 29-Jan-2016 by cgninan 1
Thank you for your response, I tried disconnect and reconnect and also reload of irules. I checked the archive folder and there is no reference or anything in that folder. I cleared connection history too. But still facing the same problem
0

Answers to this Question