Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

F5 LTM and Javascript error

Hello Experts

I am facing one issue with F5 LTM. There is one web application published on F5 with https offload. Everything is working fine, one page with javascript is not displaying anything and load page with error. Please advise what to do?

"Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0) Timestamp: Mon, 8 Dec 2014 05:59:15 UTC

Message: Syntax error Line: 855 Char: 82 Code: 0 URI: https://abc.com/arcgis_js_api/library/3.8/3.8/

Message: 'dojo' is undefined Line: 29 Char: 1 Code: 0 URI: https://abc.com/MapServer?f=jsapi

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

HTTPS offload and URL rewrites does not work fine with Java. Which application is it ? Is it some standard application or custom built ?

0
Comments on this Answer
Comment made 09-Dec-2014 by ghost-rider 393
Hi. I am not rewriting the javascript. I am just rewriting the "text" in body for http to https and hostname and location header. Could you please any possible cause of this? How I can clear the javascript loaded in to browser?
0
Comment made 10-Dec-2014 by Pratik 137
Rewriting will work with HTML but not with Java. That is why I asked which application are you using. For eg-: If its jinitiator with Oracle you have to do following settings -: http://oracle.3dub.com/2011/02/01/ssl-cert-workaround-for-oracle-forms-behind-f5/
0
Comment made 10-Dec-2014 by ghost-rider 393
I will check that. But In javascript file, there is only one URL and I manually change the real hostname and http to virtual hostname and https but also the same error. Could you give me some direction how to troubleshoot this
0
Comment made 17-Dec-2014 by Pratik 137
It won't work that way. You have to actually configure application server to use SSL, or else if you can tell the application name I can look up for ssl offload details.
0
Comment made 24-Feb-2015 by ghost-rider 393
Hi Pratik Sorry for coming back late. Actually I removed SSL to troubleshoot and still its not working. The application is using some javascript library from http://dojotoolkit.org
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Are you using AVR module and checking page load time in it?

0
Comments on this Answer
Comment made 24-Feb-2015 by ghost-rider 393
I am not using AVR
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

did you tried to change the browser, like (ms ie, firefox, chrome,...)

0
Comments on this Answer
Comment made 17-Dec-2014 by ghost-rider 393
yes .. same from all browser. Any thoughts?
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I am facing a similar issue with kronos. I have two VIPs listening on HTTP & HTTPS. The HTTP has a simple https redirect to the main page, and the HTTPS VIP with a streaming profile has the following iRule:

when HTTP_REQUEST {
    ## tell server not to compress response
    HTTP::header remove Accept-Encoding

    ## disable STREAM for request flow
    STREAM::disable
}
when HTTP_RESPONSE {
    ## catch and replace redirect headers
    if { [HTTP::header exists Location] } {
        HTTP::header replace Location [string map {"http://" "https://"} [HTTP::header Location]]
    }

    ## only look at text data
    if { [HTTP::header Content-Type] contains "text" } {

        ## create a STREAM expression to replace any http:// with https://
        STREAM::expression {@http://@https://@}

        ## enable STREAM
        STREAM::enable
    }
}

There's a run report instance that throws an undefined javascript error when accessing the web-app on the F5.

0
Comments on this Answer
Comment made 03-Feb-2016 by Rob 133
Hi, I was wondering if you ever found a solution for this and Kronos? Trying to implement version 7 and it fails loading if I rewrite with https. Thanks.
0
Comment made 04-Feb-2016 by r_dynamo 8
Hi Rob, the Kronos admins have to enable the following settings: site.webserver.applet.communication.protocol=https site.security.ssl.termination.on=true site.security.ssl.termination.host=<f5 vip fqdn></f5>
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

The rewrite irules don't work with Java. Probably you might want to edit httpd.conf and add an alias of https://hostname.

0
Comments on this Answer
Comment made 12-Aug-2015 by ghost-rider 393
Hello Pratik. You mean, enable https on real server itself?
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

The backend Servers are not using apache. What's the IIS equivalent of httpd.conf to add an alias of https://hostname.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

You can try adding it in site bindings.

0