Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral


Questions and Answers

Loading... Loading...

Hi, we ssh to our big-ips using remote-ldap authentication. I see that it takes you by default to the tmsh mode and if i do a "quit" to exit out of it so that I can get to the regular shell, it closes the whole session. Is there a way to avoid this? 


4 Answer(s):

If you are on v11 it would seem Advanced Shell access isn't possible for externally authenticated users. You can of course still use a local Administrator account.
If you run !bash and you have console access you can get to a bash prompt using remote auth.

You can also hack this a bit and add an entry to /etc/passwd for remote users to have them logged in with a bash shell by default. This isn't supported but should work.

my_remote_user:x:0:0:my_remote_user:/home/my_remote_user:/bin/bash

There's an open request for enhancement to support bash as a terminal option for remotely authenticated users:
Bug 358740 - RFE Allow bash as a shell option for remote users

You can open a case with F5 Support to request this RFE be built.

Aaron
Thanks Aaron, i put in the above entry as it is in the /etc/passwd file. It still takes me to tmsh prompt....
the fix to this is by running "run /util bash" in tmsh. Thanks to TAC...

Your answer:

You must be logged in to reply. You can login here.