Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology

GTM RTT load balancing

Hi folks, Got some problems with GTM setup. We have 3 data centers, we set up to use RTT as a load balancing. When I do query directly to F5 (external listener) to a specific wide ip, it falls back to DNS. How to make it work with RTT? May be I'm missing something. Thanks!

Rate this Question

Answers to this Question



Which lb method did you configure as alternate?

The first request from a new ip will fail until ldns probing done!

Probing is not on the fly but new ip is added to probing table.

You have to look at your gtm settings which protocol is used for ldns (ldns is the dns server which forward and cache client request) probing. (Dns, Icmp, ...)

Comments on this Answer
Comment made 12-Aug-2017 by chic_cat 55

Hi Stanislas, The way we set up our environment: Client's app hits normal DNS servers (bind) and one zone just forwards everything on F5. We set up one different Wide IPs with A records and pools inside for 3 different zones which are supposed to be load balanced with RTT. RR works just fine. So I have a couple of questions

1) where can I check "protocol settings for LDNS"?

2) In our env I believe RTT is not gonna work fine if we forward all request from ldns in our internal network to F5, so clients should resolve records directly from F5?


Comment made 13-Aug-2017 by Stanislas Piron 8056


I have no access to a gtm today, so I can't see config path of gtm settings.

In any OS, you define a dns server to relay your requests to internet servers. GTM never receive requests from clients but this dns relay server.

Comment made 13-Aug-2017 by chic_cat 55

Hi, Please check where's that option when you have time, The only one I found - System->Configuration->Device->Dns and we've already have out LDNS servers in there. Thanks

Comment made 30-Aug-2017 by chic_cat 55

Hi Stanislas, Any updates on this? Thanks