Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Clear all filters
Answers

Had anyone test Openstack LBaaS multi agent F5 solution ?

Hi, We are testing Openstack LBaaS plugin to manage F5 VE/Hardware LTM . Customer is using Centos kilo version openstack and installed F5 LBaaS v1.0.10 plugin. By now , we had tested multi agent support for F5 LBaaS plugin , here is the status: 1> 1 controller with 1 LBaaS agent to manage 1 LTM
This is ok 2> 1 controller with 1 LBaaS agent to manage 1 pair HA LTM This is not work , we can adding pools and succeed in deliver to LTM , but when we try to adding vip , the system will automatic delete the whole partition on LTM after deliver to LTM . 3> 2 controller each had 1 LBaaS agent to manage 1 LTM This is also not work , we can adding pools but failed to adding VIP , same result , VIP was deliver to LTM once , and after 10-30s , LTM will delete the VIP. We had try to enable evironment_prefix == uuid , still get the same issue. And also , for step3 , we double confirmed if enable each of the controller only , everything is OK.

So , I just wonder , have anyone here test multi agent solution for Openstack LBaaS ?

Raymond

0
Rate this Question
Comments on this Question
Comment made 02-Feb-2016 by Raymond Feng 152
Here is the agent config file : von$ grep -Ev "^$|#" f5-oslbaasv1-agent.ini [DEFAULT] debug = True periodic_interval = 10 environment_prefix = uuid static_agent_configuration_data = location:DFW1_R122_U9, service_contract:8675309, contact:jenny f5_device_type = external f5_ha_type = standalone f5_external_physical_mappings = default:trunk1:True advertised_tunnel_types = l2_population = True f5_global_routed_mode = False use_namespaces = True max_namespaces_per_tenant = 1 f5_route_domain_strictness = False f5_snat_mode = True f5_snat_addresses_per_subnet = 1 f5_common_external_networks = True f5_bigip_lbaas_device_driver = f5.oslbaasv1agent.drivers.bigip.icontrol_driver.iControlDriver icontrol_hostname = 172.168.20.13 icontrol_username = admin icontrol_password = admin icontrol_connection_retry_interval = 10 icontrol_connection_timeout = 10 icontrol_config_mode = objects
0

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Raymond,

If I understand you correctly, scenario 2 uses a single LBaaS agent to control a cluster of two BIG-IP LTMs. This is supported and tested. Standalone, HA-pair and HA-scalen operations are exercised in regression testing performed within the engineering team. I see that you have 'f5_ha_type = standalone' in your .ini file, which controls how the agent interacts with the BIG-IP(s). You'll need to set 'f5_ha_type = pair' and restart the agent. Further details on HA configuration can be found in f5-oslbaasv1-readme.pdf, which should be included in the F5 LBaaS image bundle.

Scenario 3 looks like the same bug reported to the product team last week. The team is currently working on both a fix and method to reproduce internally to verify the fix. We're not aware of a workaround at the moment that supports the use of multiple controllers and agents.

Best, Matt

0