Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

iControl - Perl Virtual Show Script - pool () was not found error

From Comments Section: https://devcentral.f5.com/wiki/iControl.PerlVirtualShow.ashx

Error if no pool assigned to VIP

I am fairly new to perl

I have a many LTM's and a few VIP's that do not have any pools assigned to them as i am doing an I-rule redirect and a few various other reasons why i do not have a pool defined for a vip's. This script runs great if all VIP's have a pool assigned however if when it hits the one that does not have a pool assigned it errors out as below. Would someone be able to help to be able to continue on even if there is no pool defined for the VIPs?

Here is the error i am seeing using the Perl Virtual Show Script.

SOAP-ENV:Server Exception caught in LocalLB::urn:iControl:LocalLB/Pool::get_lb_method() Exception: Common::OperationFailed primary_error_code : 16908342 (0x01020036) secondary_error_code : 0 error_string : 01020036:3: The requested pool () was not found.

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I just updated the CodeShare entry to disable the validation error when a empty pool is passed into subsequent calls. Give it a shot now and let me know if it works.

-Joe

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Worked Perfect. Thanks very much

I really appreciate the fast turn around and all your hard work, i have seen alot of your great work on this site.

Thanks Again,

ccna55

0
Comments on this Answer
Comment made 30-Aug-2013 by Joe Pruitt 6270
No problem at all. Glad to help!
0
Comment made 03-Oct-2014 by hcktheroot 2
hello, I am running in to the same problem - It is not working for me. Can you please help. get_lb_method and get_monitor_association : error_string : 01020036:3: The requested pool () was not found.</faultstring>
0
Comment made 03-Oct-2014 by ccna55 14
Did you go here an download the updated code? it works good for me now. https://devcentral.f5.com/wiki/iControl.PerlVirtualShow.ashx
0