Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Questions and Answers


Loading

Submitting

Internal Sites not Working through local APM proxy http://127.0.0.1:44777/

We are seeing an issue where internal sites are not working when connecting through the f5 APM edge device. We have noticed the the virutal adapter sets the proxy to us an automatic configuration script of  http://127.0.0.1:44777/. However, this is not what our clients have their proxy set to when truly on the network. If I change the virtual adapter to go to our true proxy servers or user our proxy .pac the site comes up. However, this setting only remains for a few seconds and automatically gets changed back. Why is the virtual adapter set to this and how can I configure it to just use what the browser normally uses? This is causing great pains in our organization.

Thanks!

3 Answer(s):

Hi,

Can you use group policy to push the .pac file configuration to your users and not configure the APM to provide the proxy? I have used the proxy configuration on firepass and APM without any issue. You might open a browser and point it to http://127.0.0.1:44777 and view what the pac file has in it. It might be that you provided it the wrong file.

Seth
Hi,

Can you use group policy to push the .pac file configuration to your users and not configure the APM to provide the proxy? I have used the proxy configuration on firepass and APM without any issue. You might open a browser and point it to http://127.0.0.1:44777 and view what the pac file has in it. It might be that you provided it the wrong file.

Seth

The 127. pac file is the correct file. I'm not sure how group policy would do that. We have policies in place that do set the correct proxy.pac file in IE. The issue is that APM creates it's own adapter and downloads the file locally and points VPN users to the 127. I just want the VPN adapter to use the same path as the normal IE settings.

Your answer: