Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Issue wih BIG-IP upgrade (12.1.2 to 14.0.0.4)

Today, we upgraded a BIG-IP cluster (mode Active/Active) from version 12.1.2 to version 14.0.0.4. After the upgrade, almost all applications start to fail intermittently with an error ERR_INVALID_HTTP_RESPONSE. The problem ocurred ONLY in Chrome browser, and in Firefox, Opera and Edge everything worked fine. There is no error in LTM logs. Someone has experienced this problem?

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

After some research on the Internet we found that the error was possibily related with some null characters in HTTP reponse, more specifically in HTTP headers. So we did a packet capture and found out that the BIG-IP system was sending the following Set-Cookie header filled with nulls:

Set-Cookie: f5_cspm=1234\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\000;\r\n

Since this cookie is related to the AVR feature, we disabled the HTTP analytics on all virtual servers that had this enabled, to force the BIG-IP system stop to sending this Set-Cookie. After this, we tried the upgrade again and the upgrade worked perfectly and the error ERR_INVALID_HTTP_RESPONSE did not ocurred anymore on Chrome browsers.

As a second test (for confirmation), after the upgrade we enabled the HTTP analytics profile again in some virtual servers and the issue happened again: the applications start to fail in Chrome browsers with an error message of ERR_INVALID_HTTP_RESPONSE.

So, I think is a somekind of bug in the BIG-IP for this version.

1
Comments on this Answer
Comment made 1 month ago by G. Scott Harris 1682

I have encountered the same issue with 14.0.0 and Chrome. Removing the analytics profile solved it. the cspm cookie is for client-side performance monitoring so I expect, though I haven't tested it, that disabling the "Page load time" metric in the analytics profile would also stop the error.

1
Comment made 1 month ago by Pedro Roure 211

Yes. Disabling the "Page Load Time" in the analytics profile also solves the issue (tested here).

1
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I have not seen this issue.

However, I would start by checking your iRules. For example do you have a HTTP_RESPONSE event containing multiple re-directs for a single IF condition?

0