Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Clear all filters
Answers

Need help with test LAB

Hello community. Im newebie and i need your help. I have VE LTM on VMWare Workstation 11. My real NIC in network 10.10.3.0. I have 2 virtual web servers with IP's 172.16.12.128 and 172.16.12.129. In LTM i create pool: "http_test_pool" with nodes 172.16.12.128 - 129. After that im going to create a VirtualServer for this pool with IP 192.168.5.2 with service port 80. After creating VS, when i typing address 192.168.5.2 in webrowser from my computer - i don't have a redirect to a web servers. When im typing 172.16.12.128 or 172.16.12.129 - all work. In my real NIC in properties ipv4 i added network 192.168.5.0 with default gateway 192.168.5.1 and from real PC i can ping VS IP Address 192.168.5.2

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hello,

Have you created a self ip (172.16.12.12x) on your LTM instance ? (network => self ips => create)

The LTM instance need to have an IP address in the same network than you webservers.

Cheers, Guillaume

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Yes, i already have selfIP's configuration but still doesn't work (( My other configuration: Internal VlAN (tag 100)- interface 1.1 - untagged External VLAN (tag 200)- interface 1.2 - untagged Managment IP: 192.168.20.5 Slef IP's: internal_self_IP: 172.16.12.100 external_self_IP: 192.168.5.100 Image Text Image Text

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

So how is the routing configured on the virtual web servers? Chances are they aren't returning the responses back to the BIG-IP. Just as a test to verify this, if you go to your Virtual Server configuration on the BIG-IP and set the "Source Address Translation" parameter to automap and see what happens.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Henrik Gyllkrans, THX MAN. Enable SNAT as auto and all works.

0
Comments on this Answer
Comment made 03-Nov-2015 by Henrik Gyllkrans 596
No problems. That means that the web servers did not respond back through the BIG-IP, so either use the BIG-IP as the default gateway for the servers, or use SNAT on the Virtual Servers.
0