Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

problem importing iapp

Hi guys,

i have a problem importing standard iapp (Microsoft Exchange Server 2010 (BIG-IP v11: LTM, APM, Edge Gateway). I followed deployment guide, document version 3.3. Downloaded iapp file, unzipped and tried to import but  i get an error:

"Loading configuration... /tmp/upload_template.tmpl 01070712:3: Caught configuration exception (0), ERROR app_template - /Common/f5.microsoft_exchange_2010_cas.2012_06_08 definition: line 3 [script "f5.app_utils" included from "APP_TMPL_/Common/f5.microsoft_exchange_2010_cas.2012_06_08_definition" not found] [tmsh::include "f5.app_utils"] line 115 [script "f5.app_utils" included from "APP_TMPL_/Common/f5.microsoft_exchange_2010_cas.2012_06_08_definition" not found] [tmsh::run_proc f5.app_utils:do_tmsh_create "\"$component\"" "\"$arguments\""] line 123 [script "f5.app_utils" included from "APP_TMPL_/Common/f5.microsoft_exchange_2010_cas.2012_06_08_definition" not found] [tmsh::run_proc f5.app_utils:do_tmsh_modify "\"$component\"" "\"$arguments\""] line 158 ["\d" has no meaning. Did you mean "\\d" or "d"?] [{(\d+).(\d+).(\d+)}] line 158 ["\d" has no meaning. Did you mean "\\d" or "d"?] [{(\d+).(\d+).(\d+)}] line 158 ["\d" has no meaning. Did you mean "\\d" or "d"?] [{(\d+).(\d+).(\d+)}] line 159 ["\d" has no meaning. Did you mean "\\d" or "d"?] [{(\d+).(\d Unexpected Error: Loading configuration process failed."

Any ideas?

 

Thanks

 

 

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
I just imported that template to a fresh installation of BIG-IP v11.2, and it worked fine. Tell me what version you are running and I will try to help.

-Fred
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
On BIG-IP 1600 , I am running on 11.1.0 Build 1943.0 Final.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
OK, the iApp should work on v11.1.0 also, so let's first make sure we are working with the same file. Please run an MD5 checksum on the template by running md5sum on the BIG-IP. If you are running Windows on your desktop, you can accomplish the same thing by downloading a simple MD5 checker like http://www.softpedia.com/progDownload/MD5-Checker-Download-22900.html
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Continuing from the previous post, the MD5 result should be b1e1706c7f66049efa303c8bcb071e53. If not, try downloading again. If so, there may be something wrong with your BIG-IP configuration. You should open a case with F5 support. http://www.f5.com/support/support-services/contact/

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
indeed i am getting complitely other MD5 result: b743e0fd9f7cd97c2b45c3a288b3 I tried to download few times, didnt work so i guess i should contact support.

Thanks for your help
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Check your antivirus software--that can sometimes corrupt downloads. Also, if you are using FTP for download, make sure you are in binary mode, not ascii mode.
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Same problem 11.6. ""\d" has no meaning" Trying to find an IPv6 address using the regexp: regexp -all -inline {([0-9A-Fa-f]{1,4}:){7}[0-9A-Fa-f]{1,4}|(\d{1,3}.){3}\d{1,3}} The TCL regex GUIs such as Visual Regexp accept this fine.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Calliper have you found a solution for this last issue?(regexp -all -inline {([0-9A-Fa-f]{1,4}:){7}[0-9A-Fa-f]{1,4}|(\d{1,3}.){3}\d{1,3}} I am experiencing the same issue but I do not know what could be a solution.

7: warning: ["\d" has no meaning. Did you mean "\d" or "d"?][{(?:3[4|7]\d{2})(?:[ ,-]?(?:\d{5}(?:\d{1})?)){2}|(?:4\d{3})(?:[ ,-]?(?:\d{4})){3}|(?:5[1-5]\d{2})(?:[ ,-]?(?:\d{4})){3}|(?:6011)(?:[ ,-]?(?:\d{4})){3}}]

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Since this thread is 2 years old, let's verify: Are you attempting to import an iApp from the latest package on f5.downloads.com onto a BIG-IP running 11.6? If so, which iApp file are you importing?

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Fred,

I did not notice this thread was so old :). I am going to upgrade a LTM from version 10.1 to 11.4.1 and found this issue when trying to paste the irule on box version 11(test box). However, I was trying via CLI (tmsh) with this command: "load sys config merge from-terminal" and was getting tha error. I just tried via GUI and it worked. So, I guess there must be something related to the command, but it always works and it worked for some other irules... Not sure what could be an issue.

0