Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral


Questions and Answers

Loading... Loading...

Hi All,

I have Installed LTM VE 11.1 on Vmware Workstation 8.0.3. Host machine is Windows 7 Enterprise 64-bit. I have the following network configuration on Workstation.
VMnet0
Bridged




VMnet1
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.60.0.0
Subnet Mask: 255.255.255.0




VMnet2
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.70.0.0
Subnet Mask: 255.255.255.0




VMnet3
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.80.0.0
Subnet Mask: 255.255.255.0

Vmnet3 is internal vlan, where i have 3 instances of easyPHP based Webservers, (10.80.0.2/3 &4) on Port 8080, with a small php script. Test Successfully.

I have now created a pool of these servers, and created a Virtual Server(10.70.0.201 on Port 80) in the same pool.  However, I cannot browse the webpage 10.70.0.201.  Virtual Server Settings are as follows:


a. HTTP profile set to "http"



b. SNAT Pool set to "Auto Map"



c. Default Pool set to the pool you created in the first step



d. Default Persistence Profile set to "Cookie"

Please assist at the earliest, I need to do demo on this.



a. HTTP profile set to “http”
b. SNAT Pool set to “Auto Map”
c. Default Pool set to the pool you created in the first step
d. Default Persistence Profile set to “Cookie”

Hi All,

I have Installed LTM VE 11.1 on Vmware Workstation 8.0.3. Host machine is Windows 7 Enterprise 64-bit. I have the following network configuration on Workstation.
VMnet0
Bridged


VMnet1
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.60.0.0
Subnet Mask: 255.255.255.0


VMnet2
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.70.0.0
Subnet Mask: 255.255.255.0


VMnet3
Host-only
Select “Connect a host virtual adapter to the network”
Subnet IP: 10.80.0.0
Subnet Mask: 255.255.255.0

Vmnet3 is internal vlan, where i have 3 instances of easyPHP based Webservers, (10.80.0.2/3 &4) on Port 8080, with a small php script. Test Successfully.

I have now created a pool of these servers, and created a Virtual Server(10.70.0.201 on Port 80) in the same pool. However, I cannot browse the webpage 10.70.0.201. Virtual Server Settings are as follows:

a. HTTP profile set to "http"

b. SNAT Pool set to "Auto Map"

c. Default Pool set to the pool you created in the first step

d. Default Persistence Profile set to "Cookie"

a. HTTP profile set to “http”
b. SNAT Pool set to “Auto Map”
c. Default Pool set to the pool you created in the first step
d. Default Persistence Profile set to “Cookie”



I am able to ping Virtual Server from F5 VE Self IP and Localhost...

Please assist.


2 Answer(s):

I'm guessing that the network topology of VMnet1 and VMnet2 are not aligned. This is common with VMware Workstation (but, hey, unsupported!)

I would verify that the configured NIC's MAC addresses line up between the hypervisor and the BIG-IP VE. ping and arp are useful for troubleshooting these sorts of scenarios as well. (I'd try pinging the 10.70 self-ip from my workstation)

to work around, you can do the BIG-IP method or VMware method.

BIG-IP method:
Reconfigure your vlans in BIG-IP. If VMnet2 was supposed to be on 1.2 and VMnet1 is on 1.1, try setting VMnet2 to 1.1 and VMnet1 to 1.2.

VMware method:
you can reconfigure the vlan assignment on the hypervisor side - assign interface 1's vlan to interface 2, and vice versa.


i am having the same problem... ive verified that my adapters macs are on the correct interfaces. ive been beating my head against the wall with this basic issue for almost 2 weeks. ive even modified my vmnet0 and placed it on the same /24 subnet as my outside self ip and my virtual server destination address to no avail. im new to vmware and bigip but even with all my googling and searching ive not found to many instances of people having this issue. of course the one i do find (this one) and theres no more than 1 response :) my luck

anyone? bueller? bueller??

Your answer:

You must be logged in to reply. You can login here.