Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Problems with MAC Masquerading on LTM VE

Has anyone used MAC Masquerading with VE?  I have everything working great, and as soon as I enable masquerading on a VLAN I can no longer ping the VIP, or connect to it.  I am using the current demo version of 10.1.0 Build 3341.1084.

1
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
If anyone is interested in this I found the problem. I needed to enable promiscuous support for the vswitch in esxi.

Use of VLAN groups (CR137596)
Use of VLAN groups with BIG-IP Local Traffic Manager VE requires proper configuration of VMware vSwitch or VMware vSwitch portgroup security policies. The Promiscuous Mode and Forged Transmits properties must be set to Accept. By default, Promiscuous Mode is set to Reject. For information on how to configure these options, refer to the vSwitch sections of VMware's vSphere manuals.
1
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Hey Adam,

Just a quick note to say good man for posting your solution !!!

Ive just spent 2 days wailing and gnashing my teeth trying to figure this out on my cluster until I found your gem. As you outlined I enabled promiscious mode on my vswitch and all was well in my F5 world

Thankyou !!!

Rgds
Tom

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Many Many thanks for that one. I would struggle for ages if I did not find this post :)

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

2x Many Many thanks for that one. I would struggle for ages if I did not find this post :)

0