Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral


Questions and Answers

Loading... Loading...

From time to time we get issues with different clients using Network Access and App Tunnels. From one day to the other a client suddenly gets "The modem (or other connecting device) has reported an error", when starting Network Access. When they try to open a RDP App Tunnel, they get the message "WARNING! The local TCP port number used by the App Tunnel adapter for the application you are trying to connect to has changed due to conflicts with another application on your system" The RDP session then connects to the local computer.

This happes without no modification to the client computer (hardware changes, patches etc. )

What I have tried to fix the issue:

urvpn.exe - uninstall adapter (also tried installing adapter this way)
f5wininfo.exe - Remove all components
Deleting F5 folder under Program Files
Resetting TCPIP with "netsh interface ip reset c:\resetlog.txt"

After a reboot, all software is installed again at first logon to the vpn portal, but still the problems remain.

Installing the VPN local client will also throw the same errors.

I have also enabled RAS tracing on the clients, but the logs here only points to the 651 error as seen below.


From logterminal.txt: (capture form a Network Access connection)

(DIALER:772,760) QueryDriverCapabilities()::m_Capabilities 0xf!!!
(DIALER:772,760) UIpForwardTable::CacheIPAddressTable:Cache IP address table.
(DIALER:772,760) IP address table
(DIALER:772,760) #0 10.145.99.130\255.255.255.0 IF=0x2
(DIALER:772,760) #1 127.0.0.1\255.0.0.0 IF=0x1
(DIALER:772,760) UIpForwardTable:atchRouteTable: Trying to add public route to (Correct_external_ip_of_Firepass_device)
(DIALER:772,760) UIpForwardTable::GetIfIndex: failed to find iface for addr 255.255.255.255
(DIALER:772,760) UIpForwardTable::GetIfIndex: failed to find iface for addr 10.145.99.1
(DIALER:772,760) CDialer:nCallback:Error occurred =651
(HOST:772,760) CControlData::DispatchEvent(OnError)
(HOST:772,760) CHostCtrl::DispatchEvent:Fired event OnError Number of arguments - 2
(HOST:772,760) CHostCtrl::DispatchVPNEvent(OnError,The modem (or other connecting device) has reported an error.)
(HOST:772,760) CHostCtrl:roxyIsUI:IsWaitUI failed (269)
(HOST:772,2828) CHostCtrl:ostProcessProxyDataThreadProc:Entering
(HOST:772,2828) CHostCtrl:ostProcessProxyDataThreadProc:Thread finished
(HOST:772,760) CHostCtrl::DispatchVPNEvent: return 0x0
(DIALER:772,760) CDialer::Failed - Enter


I know a reinstall of the computer fixes the problem, but that will not be a usable solution for the long run.
Our FP has firmware 6.0.3.


Any help highly appreciated!

1 Answer(s):

Umm I am pretty sure the local port you are using is being blocked or denied access. I would use something else (127.0.0.1) is a default for many many many applications.

Your answer:

You must be logged in to reply. You can login here.