Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Server Pool not coming up in Big Ip LTM VE(virtual edition) 90 days trial version

Hi ,

I am setting up a Big-Ip lab using the Big Ip LTM VE(virtual edition) 90 days trial version, I am following the Keith Barker CBT nuggets to create the lab and using his resources provided in the nuggetlab file. I have created three nodes and have added them in a pool , i have added a default http health monitor to server pool , but my pool is showing offline(Red) with a description "offline(enabled- the children pool members are down)" and my nodes are in unknown status. If i use ICMP as a health monitor , my pool and nodes becomes available(green).Below is the troubleshooting i have done.

  1. i can ping all the three nodes from the BIg-IP command line utility.
  2. I can telnet to all the three nodes at port 80
  3. I checked that server gives the proper response(Header and body) of the webpage using " get / http/1.1" command.
  4. "tmsh list /ltm monitor http" shows the default interval/timeout values.
  5. I have restarted the big Ip virtual appliance multiple times.
  6. I have removed and reconfigured the nodes and pool multiple times.

Attached are the screen shots. Please suggest where i am wrong and what else i can check or this is a limitation in this trial version.

Any help is highly appreciated.

Regards kamal

Image TextImage TextImage TextImage TextImage Text

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

You're looking at Node Level checking - I don't think you'll have enabled node level checking by default.

what does it show in the pool you've added the members to ?

Also - if you ran a tcpdump on the back end of the F5 - are you getting a response back from your health checking traffic ?

tcpdump -i 0.0 host (IP of server) and (port of server)

Remove the brackets.

Let us know how you get on.

0
Comments on this Answer
Comment made 08-Sep-2016 by PARMAR 2

Hi Thomson,

I also tried the node level health check using the "node default" option in the node configuration page, but that also didn't help.

Regards kamal

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Thomsan,

Thanks for your reply.

Pool shows "Offline (Enabled) - The children pool member(s) are down". Image Text

i started the capture and stopped the capture after a minute but I don't see any traffic when I do a tcpdump -i 0.0 host 10.2.0.22 and 80 Image Text

Regards kamal

0
Comments on this Answer
Comment made 11-Sep-2016 by boneyard 4610

i believe it is port 80 and why write to a file to then open it? for just checking if traffic is flowing in a test environment use the screen as output.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I am facing this same issue. Can anyone check and provide a solution ?

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Reviewed above post but no where seen curl output. I believe back-end server is up & port is not learning with HTTP service.

Check below thing to troubleshoot further. 1) Directly hit to back end server through browser and check you are getting page

 http://x.x.x.x:80     --> Here x.x.x.x will be back end server IP with 80 port



2) Attach curl & telnet output to check further

   curl -gv http://x.x.x.x:80 
   telnet x.x.x.x:80 

Does it makes sense?

0
Comments on this Answer
Comment made 3 months ago by plethore 118

I had a similar issue, when using the 90 day trial for the CBT Nuggets lab, the Pool would show down. What my issue was the default HTTP monitor being used.

I created a new monitor under Local Traffic -> Monitors

Name http_11.3

Parent Monitor - http

Send String: GET / HTTP/1.0\r\n\r\n

Leave other options as the defaults.

Then under Local Traffic -> Pool choose the OUR-WEB-SERVER pool. In the Health Monitors section add the http_11.3 monitor and remove the http monitor, and make sure to update the configuration.

See if that works.

0