Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

The VS do not direct to servers pool

Hello I am with follow issue: Is not working the call do virtual server to server pool using BIG-IP LTM with the version 11.2.1 Build 797.0 Final . I have another box BIGIP LTM with the version 10.1.0 Build 3341.0 Final and the same configuration it is working fine. Is there any change in how to create VS from version 10.1.0 to 11.2.1?

Regards,

Jackson

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hello Jackson,

The system for creating virtual servers across BIG-IP versions is basically exactly the same. For a list of any differences, you can check F5's version notes.

You can find the published notes on changes/fixes for ver 10 HERE.

And you can find the published notes on changes/fixes for ver 11 HERE.

I think there might be a separate issue going on with your configuration. Do you have any more information about the specific error you are getting?

0
Comments on this Answer
Comment made 1 month ago by Subrun 60

--- Do you see pool is up ?

--- Did you add right pool to the VIP ?

--- What is the Pool Status ? Is it Green ?

--- Is the VIP configured with SNAT ( Automap or SNAT ) ?

--- Are you getting Ping reply to the node and pool members from F5 ?

--- Are the VLAN tagging is done correctly ?

--- Are the VIP enabled from Virtual Address List and Server List ?

etc :-)

0
Comment made 1 month ago by JacksonFranco 55

Hi Subrun and AMiles,

--- Do you see pool is up ? Yes, Pool is up.

--- Did you add right pool to the VIP ? Yes, I did.

--- What is the Pool Status ? Is it Green ? Is Green

--- Is the VIP configured with SNAT ( Automap or SNAT ) ? Automap

--- Are you getting Ping reply to the node and pool members from F5 ? Yes, returns ping reply with success in all pool members

--- Are the VLAN tagging is done correctly ? Yes

--- Are the VIP enabled from Virtual Address List and Server List ? Yes, VIP is enabled in VS and List and Server List

An iRule is used to pass the application url. when HTTP_REQUEST { if {[HTTP :: uri] eq "/"} { HTTP :: uri "/apex/apex.jnlp" } } Follows log output: Feb 7 21:49:04 tmm1 info tmm1 [7319]: Rule /Common/log : URL: navistvv/apex/apex.jnlp Feb 7 21:49:04 tmm1 info tmm1 [7319]: Rule /Common/log : 172.27.224.134:80 Feb 7 21:49:05 tmm info tmm [7318]: Rule /Common/log : URL: navistvv/apex/apex.jnlp Feb 7 21:49:05 tmm info tmm [7318]: Rule /Common/log : 172.27.224.134:80

Is there any iRule that I can see the switch to the server pool?

Regards,

0
Comment made 1 month ago by Subrun 60

tcpdump -vnno 0.0:nnnp -s 0 host IP ( in IP you can put source ip )

try to see with this tcpdump if you find any clue.

0
Comment made 1 month ago by JacksonFranco 55

Hi Subrun,

Thank you for help. With tcpdump I identified that a routing to the VLAN for the pool servers was missing. My data center network is segmented into 4 VLANs. And was missing one route. After add route the connection it is working.

Regards,

Jackson

0
Comment made 1 month ago by Subrun 60

Hello Jackson-- Good to know issue is resolved. Thank You...

0