Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

upgrade issue going from 11.5.3 HF2 to 12.1.1 HF1

Hi,

Wondering if anyone has attempted to upgrade from version 11.5.3 HF2 to 12.1.1 HF1? I have tried numerous times and received the following error...

error: status 256 returned by command: F5_INSTALL_MODE=install F5_INSTALL_SESSIO N_TYPE=hotfix chroot /mnt/tm_install/23323.1odTKH /bin/touch /service/mcpd/force load info: >++++ result: info: /bin/touch: cannot touch `/service/mcpd/forceload': Permission denied info: >---- Creation of mcp db force-load flag failed; No such file or directory umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy umount: /mnt/tm_install/23323.1odTKH: device is busy

I have referenced the following links for the error above: https://support.f5.com/kb/en-us/solutions/public/17000/200/sol17240.html https://support.f5.com/kb/en-us/solutions/public/15000/200/sol15243.html https://support.f5.com/kb/en-us/solutions/public/13000/000/sol13030.html

but none of them provided a viable solution. I have tried the upgrade via GUI and CLI, and have not had any success. I have LTM and ASM activated on my 3900s...

TIA...

VT

0
Rate this Discussion
Comments on this Discussion
Comment made 29-Nov-2016 by Tikka Nagi

Without seeing the qkview from the device it's not clear what may have gone wrong.

Please try:

tmsh modify sys db liveinstall.moveconfig value disable modify sys db liveinstall.saveconfig value disable install sys software image BIGIP-<...>.iso reboot

If this doesn't help please open a support case.

0
Comment made 30-Nov-2016 by Vincent 91

I've got F5 support via Nexum. I've given them my UCS file and they are trying to simulate the upgrade in the lab. Just trying a different avenue to see if anyone has experienced the same symptoms...

0
Comment made 06-Feb-2017 by sasa 1

I'm running into the same issue when upgrading from 11.5.0 to 12.1.2. Are there any updates to this? I have a case open with F5 and waiting to hear back.

0
Comment made 24-Mar-2017 by chenhaitao02 1

I'm upgrade from version 11.5.4 HF2 to 12.1.1 received the same error...how do you fix this question?

0

Replies to this Discussion

placeholder+image

Same issue here. will be putting in a case soon if no one has found a fix yet.

0
placeholder+image

I just ran into this issue too mocking up 2 upgrades going from 11.5.4HF2 to 12.1.2HF1 (11.5.4 on HD1.2 and 12.1.2HF1 on HD1.1). First one went fine, but then the 2nd one is where I ran into this. "cpcfg" gave me the error "you must specify the filesystem type". It wouldn't let me reinstall the software to the volume either. I even tried deleting the volume and got the error "failed to delete volume". But somehow, after I got that error the volume disappeared and I was able to to an install to a 'new' volume with the same # (HD1.1). Then the 2nd upgrade worked. What did F5 say about this problem?

0
placeholder+image

Nothing? Same issue here. About to have to open a case. Been fighting this one VE upgrade from 11.6 to 12.1.2 HF1 .

info: Getting configuration from HD1.2 info: Copying configuration to HD1.1 info: Applying configuration to HD1.1 info: >++++ result: cannot touch `/service/mcpd/forceload': Permission denied

0
placeholder+image

I could resolve the same issue (trying 11.5.3 -> 12.1.2 HF2) by installing 12.1.2 HF1 instead, booting into this Boot Location, then installing HF2 in the other Boot Location and booting into HF2.

0
placeholder+image

Hi

I had issues when upgrading from 11.6.1 >> 12.1.3.5 .

It can not copy the config to the new HD and get error as below.

Image Text

FIX is :

I upgraded to the new firmware without copying the configuration. Once the new firmware is loaded, I manually uploaded the config to the box. This fix the error above.

Strangely I only faced the error on the passive unit. On the active unit, I did not need to load the config manually.

0