Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology

URI Rewrite profile not use the full path of the url

Hi , I have configure content rewrite profile to make f5 as a reverse proxyso if a client request to this will be the client side and for the server side i want my F5 to use this link to talk to my server but unfortunately F5 doesnt take the full URi it just talk to server using that what i should do to make F5 to talk to server on the full url ?

Rate this Question
Comments on this Question
Comment made 1 week ago by rafaelbn 328

Hello Ahmed Eldosouki,

I think that content rewrite profiles are meant to rewrite the packet payload, not the URL. I think you could achieve a solution by just doing a redirect? A simple policy that redirects the client to the new/complete URL should do the trick and be easier on BIG-IP's CPU.

Cheers, Rafael!

Comment made 6 days ago by Ahmed Eldosouki 53

hi Rafael, Thank you for your comment, i didnt want the client to be redirected to any thing i just want to use F5 as a revers Proxy, by the way i made it using iRule and content Rewrite profile

Comment made 6 days ago by rafaelbn 328

Great news Ahmed! Cheers!


Answers to this Question



I haven't completely played around with rewrite profile, so far been using Irules. But your requirement still should be able achievable through rewrite profile. May I know how you had the new custom profile created ?

Because, /signserver/tsa?workerName=TimeStampSigner1101/ is still a URI, where workerName=TimeStampSigner1101 would be your HTTP QUERY, workerName will be your QUERY PARAMETER and TimeStampSigner1101 will be its VALUE.

So while creating your rewrite profile, did you follow,

Let us know how it goes.

Comments on this Answer
Comment made 6 days ago by Ahmed Eldosouki 53

hi jaikumar, i have already did it but the problem with rewrite Profile is it just translate URI not the Querystring (tsa?workerName=TimeStampSigner1101/) So i used Irule and it is working