Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

vCMP Guests - Traffic Group shows "Initializing / Not Synced"

Folks,

I have two vCMP guests on a Viprion blade that were on 11.3 HF5 with no issues but as of a few minutes ago are now on 11.3 HF9. The configs have synced across peers - I have pretty green indicators in the top left hand side of the GUI. But when I navigate to Device Management -> Traffic Groups, the "Next Active Device" field says, Initializing / Not Synced." What can I do to correct this? What is the issue that has caused this to happen?

Thanks,

Timothy

1
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Timothy,

Please check below site: http://support.f5.com/kb/en-us/solutions/public/13000/900/sol13946.html

Above site link will have good info which could be found for configsync DSC issues... I had seen similar issue on Viprion chassis.,but resolved after reboot of vCMPs..

But the above link will provide more information specific to mcpd service.. link on core system services info: http://support.f5.com/kb/en-us/products/big-ip_ltm/manuals/product/tmos_management_guide_10_1/tmos_appendix_c_system_services.html

-2
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi,

Try to execute save /sys config partitions all and then see if the Next Active Device is synced..This problem occurs if we have nodes or objects mismatch in either of the sync devices.. or Are the devices rebooted after hotfix HF9?

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I didn't explain it well to start with. I have vCMP guests that are peers on two different Viprions. They were running fine with 11.3 HF5 but with the upgrade to 11.3 HF9 they appear to be ok (I can sync the configs) but the traffic group has a status of "Initializing / Not Synced."

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

To both of the guests I have saved the config:

tmsh: save sys config partitions all

When navigating to Device Management -> Traffic Groups, the "Next Active Device" field still says, "Initializing / Not Synced."

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I haven't done a comparison of the objects through the config file to know if there are objects that haven't been synchronised across peers but a glance through the GUI seems ok.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Thanks, hari. I worked all the way through Sol13946, the doc that you referenced above, and right at the bottom was the if-all-else-fails reset trust. So I did. I had to add the peer into the failover group since it had lost trust and then I resynced the boxes and it’s happy again. Thank you for your help.

Timothy

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Same exact thing happened to me on a 11.6.0 upgrade. Nothing in the above thread has addressed this. Resetting device trust has no effect other than both Ltms go active until the traffic and device groups are rebuilt

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Same problem here.....

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Someone got any news from F5 Support about this situation?

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

More info; the result of a "tmsh show /cm traffic-group traffic-group-1 auto-failback-enabled" run on each LTM.

TLDR--The active LTM does not see the standby LTM as being online. The standby LTM does view the Active LTM correctly

Active config # tmsh show /cm traffic-group traffic-group-1

CM::Traffic-Group traffic-group-1 standbyF5.net.unc.edu offline false traffic-group-1 ActiveF5.net.unc.edu active false

Standby config # tmsh show /cm traffic-group traffic-group-1

traffic-group-1 standbyF5.net.unc.edu standby true traffic-group-1 ActiveF5.net.unc.edu active false

Both LTMs are synced, but on the Primary LTM the traffic group lists only the Active LTM--as "current device"

Underneath that is "Next Active Device Initializing / Not Synced"

Essentially, the active F5 does not see the standby as being in its traffic group, even though both appear in the HA order box, even though the standby does sees the active. The gui on each is exactly the same, save that on the standby, the correct ltm name appears as "Next Active Device"

Testing this on a virtual pair with no traffic, and I found that if I force the primary to standby, 1. The previous standby LTM will go Active 2. Then the originally active LTM goes active AGAIN 3. And the previous standby LTM falls back to standby.

So the standby LTM behaves as it should, but as far as the primary is concerned, it is the only active ltm in the traffic group. Auto-failback is NOT enabled on either LTM.

I just upgraded three pairs of virtual LTMs from 11.4.1 to 11.6.0 on our Viprions, and each pair has the same exact problem. Also, each of the Active LTMS with the issue are hosted on the same Viprion chassis, so there may be an issue on the chassis itself forcing the behaviour, but I am damned if I can figure out what it would be.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Ok. Never really heard back from F=5 on this, but I have managed to fix the issue.

As best as I can tell, this is what did it.

First, set the management ip as the Network failover address on each server, in addition to any other ips.

Second, reboot whichever LTM is refusing to see the other member as an active member of the HA order.

Each time I've done this, the primary has come back and accepted its role as the new Standby.

IF this still does not work--destroy all trust on both LTMs chosing the create new certs option on each, remove the opposite member of the pair from all device and traffic groups, and delete the peers. Then rebuild from one LTM only--though both will be active at this point. Once that is done, choose one and reboot.

0
Comments on this Answer
Comment made 27-Jan-2015 by Audreym 0
Did you ever get any information back from F5? I have this same exact problem and they have been sitting on the ticket for 3 months. Worked through all of the steps in SOL13946. All of our vlan's match. Thanks.
0
Comment made 28-Jan-2015 by sstafford 61
Rebooting the LTM that was refusing to see the other member as an active member is the only thing that worked for us-F5 never did address the issue
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

I saw this too. I tried everything including rebuilding device trust. What it turned out to be was my defined vlans didn't match. I had an old vlan that was decommissioned left on the standby. Took us all a while to figure it out but that was it. As soon as we got the same vlans defined on both sites the traffic groups showed a next active device correctly.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

disable vlan failsafe (or any other failsafes configured) and you will likely have better results

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

For us the following worked on version 11.6.0 HF4: "bigstart restart sod"

Because you will restart this process, the load balancer will again check his traffic groups and status. We saw that the 'next device option' has been filled in with the other node.

After this we were possible to put the active node in standby modes and otherwise.

Remember: After a reload/reboot of the node the same behavior can be coming back. So check this we you do a reload of a reboot.

This is known bug by F5 and haven't been solved in the version 11.6.0. HF4.

Regards,

Frans van Dokkumburg

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

The other option what it can be is that you forget to set the "enabled" option wihtin the sync-failover setting

Device Management >> Device Groups

Go to the Group what have as type "Sync-Failover" Go to the Tab "Failover"

check the "enabled" checkbox

0