Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Clear all filters
Answers

Virtual Server even when default pool is down when iRule is assigned.

Hi,

We are configuring GTMs to load balance two DCs and I am facing an issue as VS never goes down then they have an iRule assigned even though the pool associated is down. We want to rely on iQuery and make sure the GTMs removed the VS which has the pool down in one DC without having to add any extra monitoring to the GTMs.

Is that possible?

Thanks, Wahezu.

0
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

what I've done in the past is configure a dummy VS on the LTM and associate it with the pool in question. Then in the GTM member config have that dummy VS as a dependancy on the main VS member. Therefore if the pool goes down and hence the dummy VS then the main VS will go down.

cheers

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Sorry, the title of the question should be "Virtual server with iRule assigned is UP even when default pool is down".

THanks arpydays for your answer but I guess there should be another way of doing that without creating rubbish. We have a very high number of VS/pools and if I have to create one dummy VS just to cheat the GTMs it will add a lot of unnecessary lines to the config.

Thanks, Wahezu.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hello,

Recently I had the same problem. If you are using iRule with HSL::open -proto ... syntax, change it to HSL::open -publisher ..., it was a solution in my case.

Regards, Piotr Bratkowski

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Piotr,

Thanks for your comment. I changed all references to "HSL:: open -proto" by "HSL::open -publisher" and the VS is going down if the default pool is down and therefore GTM is detecting the VS down without having to create a "DUMMY" virtual server just for this.

Thanks a lot, I even created a case with F5 support and they couldn't identify the issue. How did you realize it was the problem?

Thanks, Wahezu.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hello,

I've also created support case and they didn't even look at my issue, because it was iRule related. I had a feeling that such basic functionality failing must be connected somehow to iRules, so I just detached all my iRules and then gradually identify problematic line;)

Regards, Piotr Bratkowski

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

According to the following Solution Article, you need to "Set a variable to reference the HSL pool and substitute the pool name with the variable for the HSL::open command."

SOL14505: The BIG-IP system may erroneously mark a virtual server as available when the associated pool status is offline

set mypool myexamplehslpool 
set hsl [HSL::open -proto UDP -pool $mypool]
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

If you use a Traffic Policy instead of an iRule on v12.1.2 you don't get the same behavior as the irule. The VS goes down even if the path-match pool is up. I have successfully tested. Hopefully F5 doesn't screw it up in a new OS version to make Traffic Policies more like iRules.

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

In version 13, when you drop all pools in traffic policy - the VS does not goes down(. Maybe i miss something. Dan Please show your settings.

0