Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

When upgrading to 11, I get "The configuration has not yet loaded" error

Hello all,

I have a fairly new LTM only implementation that was running 10.2.2.  I wanted to upgrade to 11 before putting it into production.  The only thing on here right now is Exchagne 2010 objects from running the Excahnge 2010 template.  When I tried to upgrade to 11, it seems to install fine, but when I boot into it, it has a yellow band across the top saying that "The configuration has not yet loaded. If this message persists, it may indicate a configuration problem"  and all objects are gone.  I followed all documentation exactly about 4 times on both nodes.  Same result.  I also upgraded it to 10.2.4 to see if that made a difference, but nothing.  Searching I found a known issue about a Citrix irule with double quotes causing it, but I am not using that particualr one.  any help would be appreciated. 

Thanks.

1
Rate this Question

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
I wanted to post the workaround in case anybody has the same issue and stumbles upon this thread. Basically i had to ssh to it and manually delete the whole line "parent id 0" from each route domain. Then run "/usr/libexec/bigpipe daol" which finishes the conversion. Then you can go into each route domain and set the parent id back to 0. Hope that helps someone!

Steve
1
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
We found a number of issues that can cause the config not to migrate successfully from v10 (I'm also on 10.2.2) to v11. Hopefully this may again help someone else!

The issue you encountered is apparently caused by a change in the route domain configuration syntax - from "parent id" to "parent name". You might want to check you re-add the parent configuration to your route domain after the upgrade as simply removing it and loading means it will no longer have a parent set.

Other changes I am aware of from my upgrade to be wary of:
- If you refer to virtuals in iRules, instead of referring simply to the virtual name (e.g. Virtual1), you now need to change the iRule to refer to the partition as well as the virtual name i.e. /partitionname/Virtual1
- Logging behaviour has changed - so it no longer automatically logs APM session logs into syslog (now goes into a MySQL database). So if you refer to or use the /var/log/apm file at all you need to re-enable this using the command
tmsh modify sys db log.access.syslog enable
- If you did advanced customisation using advCustHelp to manually modify the inc files they are not moved over in the migration. Those customisations done in the Admin GUI are carried over.

I also got another weird error when I upgraded, after running the bigpipe daol command, not sure why, which was in the format of:

01070712:3: Caught configuration exception (0), Failed: name(/Common/ca-bundle.crt.preremoval) No copy in trash-bin to restore from. - sys/validation/FileObject.cpp, line 2899.

This was one error, there were a couple of different files with the same error - all seemed to refer to *.crt certificate files though.
I was able to get around this by copying the object to where it needed to be and then rerunning the bigpipe daol:

cp -pi /config/ssl/ssl.crt/ca-bundle.crt.preremoval /config/filestore/.file_object_upgrade_staging/

All the best!
Evan
1
Comments on this Answer
Comment made 02-Sep-2013 by F5-User 0
Hey - thank you. I was having the same problem upgrading from version 10.2 to 11.4 - I ran the command above /usr/libexec/bigpipe daol and this resolved my particular case. Thanks again
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Steve,
I ran into some similar issues, most likely there is something configured that is not fully compatible with 11.x.

Run this command and post what errors you get.

"/usr/libexec/bigpipe daol"
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Thanks for the response,
Ok I ran the command as suggested and here is the error below. At least I am on the right track now.

BIGpipe parsing error (/config/bigpipe/bigip_base.conf Line 103):
012e0020:3: The requested item (1 {) is invalid ( | show | list | edit | delete) for 'route'.
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
What's the full object that starts on line 103?

Aaron
0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER
Posted By hoolio on 05/07/2012 02:17 PM
What's the full object that starts on line 103?

Aaron



It is starting at 103:
 route domain 1 {
   id 1
   parent id 0
   description "Route_Domain_1"
   vlans production_300
}


So looks like it doesn't like the formatting of the route domain?  I did find this similar KB article, however, we are not using proxy exclude:

http://support.f5.com/kb/en-us/solu...13183.html

0