Learn F5 Technologies, Get Answers & Share Community Solutions Join DevCentral

Filter by:
  • Solution
  • Technology
Answers

Wildcard parameter not matched by ASM policy

I have a wildcard parameter [{"order":".* In the learnings I see entries like [{"order":"400000465533","artikel":"1161","vestiging":"0800","magazijn":"p024","hoeveelheid":3}] not matching the configured wildcard parameter but rather the * parameter that is still in there for the learnings. If I run this through the RegExp Validator, it matches the entire parameter. So why is it not matching in my ASM policy?

Running version 11.2.1 HF14

0
Rate this Question
Comments on this Question
Comment made 03-Aug-2015 by Mike Maher 410
I am having a similar problem where I am setting up a few parameters like this as a wildcard acctAllocs[*].allocTypes[*].amt The * should just be numeric values, but I am still seeing blocks. Any thoughts on how to make this work would be appreciated.
0
Comment made 03-Aug-2015 by Mike Maher 410
So I removed the [] and the . and it seems to work. I am just curious why and if there is any documentation that shows what can and cannot be used. acctAllocs*allocTypes*amt
0

Answers to this Question

placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Will it work if you replace order:.* with order:* ? (Remove the dot)

0
placeholder+image
USER ACCEPTED ANSWER & F5 ACCEPTED ANSWER

Hi Hannes, Removing the dot works, but I've had cases where just * at the end doesn't cover everything. I think it doesn't work when there is a / furtheron in the name, but I'm not sure anymore. That's why I had the .* If I have that happen again I will update.

0